Is PHP7 al beschikbaar bij Brinkman.IT Hosting?

PHP7 is een snelle, betrouwbare, nieuwe versie van PHP die al enige tijd beschikbaar is. De voorlaatste versie is PHP 5.6. PHP6 is overgeslagen want die is nooit productierijp geworden.

Regelmatig krijgen wij de vraag wanneer PHP7 beschikbaar is. Want CMS-systemen als Joomla promoten het gebruik er van. Op de meeste servers hebben wij nog PHP 5.6.x en ook nog oudere (via keuzemenu) beschikbaar.

Op de NederNet CloudServers kunt u verschillende PHP-versies activeren. Bijvoorbeeld PHP 5.5 en hoger, inclusief PHP7. Op de server waar onze hoofdsite, https://www.brinkman.it, is gehost is PHP7 standaard. Op deze server worden echter geen sites voor cliënten gehost, alleen onze eigen projecten.

Is PHP7 veel sneller?

Er wordt vaak gedacht en beweerd dat PHP7 uw website veel sneller maakt. Dit is alleen het geval wanneer u veel, of eigenlijk exclusief, PHP-code gebruikt. Voor bijvoorbeeld de gemiddelde WordPress website (die veel MySQL gebruikt of MariaDB) zijn de verschillen niet of nauwelijks meetbaar.

Wij hebben diverse testen gedaan en hebben geen opmerkelijke verschillen kunnen vaststellen. Desondanks heeft PHP7 natuurlijk de toekomst. Ook op onze andere servers zal het daarom in de toekomst beschikbaar komen.

Bij benchmark testen komt PHP7 tot 2.6x sneller uit de bus en er is dus wel degelijk winst te boeken. Hoe deze benchmarks zijn uitgevoerd is helaas niet duidelijk. In de praktijk van alledag valt de winst tegen, 2.6x sneller is zeker niet standaard te noemen.

Wilt u nu al gebruik maken van PHP7, dan kunt u kiezen voor het hosten op ons cloudplatform. Zie http://www.nedernet.nl voor meer informatie.

Waarom is PHP7 nog niet standaard op alle servers?

De belangrijkste reden om vooralsnog niet te upgraden op alle machines is het feit dat PHP7 niet ”backwards compatible” is met oude(re) php-code. Als wij de servers zouden updaten op dit moment zou dit betekenen dat veel klanten geconfronteerd worden met websites die niet meer werken of foutmeldingen geven.

Reageren is niet mogelijk